What’s Vulnerable › Vulnerabilities
CVE-2017-16897
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-27 · updated 2026-06-17
- Weakness: CWE-290
Description
A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).
Affected products
- auth0 passport-wsfed-saml2: before 3.0.5 — fixed in 3.0.5
How to fix
Upgrade to a fixed version: auth0 passport-wsfed-saml2 3.0.5. Check the vendor advisory for mitigations.
References
- https://auth0.com/docs/security/bulletins/cve-2017-16897
- https://auth0.com/docs/security/bulletins/cve-2017-16897
Get alerted when CVE-2017-16897 or the next vulnerability affects your stack