What’s Vulnerable › Vulnerabilities
CVE-2017-16909
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-119
Description
An error related to the "LibRaw::panasonic_load_raw()" function (dcraw_common.cpp) in LibRaw versions prior to 0.18.6 can be exploited to cause a heap-based buffer overflow and subsequently cause a crash via a specially crafted TIFF image.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- LibRaw: before 0.18.6 — fixed in 0.18.6
How to fix
Upgrade to a fixed version: LibRaw 0.18.6. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/f1394822a0152ceed77815eafa5cac4e8baab10a
- https://secuniaresearch.flexerasoftware.com/advisories/76000/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2017-19/
- https://usn.ubuntu.com/3615-1/
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/f1394822a0152ceed77815eafa5cac4e8baab10a
- https://secuniaresearch.flexerasoftware.com/advisories/76000/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2017-19/
- https://usn.ubuntu.com/3615-1/
Get alerted when CVE-2017-16909 or the next vulnerability affects your stack