What’s Vulnerable › Vulnerabilities
CVE-2017-16910
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-125
Description
An error within the "LibRaw::xtrans_interpolate()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.6 can be exploited to cause an invalid read memory access and subsequently a Denial of Service condition.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- LibRaw: before 0.18.6 — fixed in 0.18.6
How to fix
Upgrade to a fixed version: LibRaw 0.18.6. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/5563e6ddc3f7cb93d98b491194ceebdee7288d36
- https://secuniaresearch.flexerasoftware.com/advisories/76000/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2017-19/
- https://usn.ubuntu.com/3615-1/
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/5563e6ddc3f7cb93d98b491194ceebdee7288d36
- https://secuniaresearch.flexerasoftware.com/advisories/76000/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2017-19/
- https://usn.ubuntu.com/3615-1/
Get alerted when CVE-2017-16910 or the next vulnerability affects your stack