What’s Vulnerable › Vulnerabilities
CVE-2017-16911
- Severity: medium (CVSS 4.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-31 · updated 2026-06-17
- Weakness: CWE-200
Description
The vhci_hcd driver in the Linux Kernel before version 4.14.8 and 4.4.114 allows allows local attackers to disclose kernel memory addresses. Successful exploitation requires that a USB device is attached over IP.
Affected products
- Linux kernel: from 4.4.0 before 4.4.114; from 4.9.0 before 4.9.79; from 4.14.0 before 4.14.8 — fixed in 4.14.8, 4.4.114, 4.9.79
How to fix
Upgrade to a fixed version: Linux kernel 4.14.8, 4.4.114, 4.9.79. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102156
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.8
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.114
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit/drivers/usb/usbip?id=2f2d0088eb93db5c649d2a5e34a3800a8a935fc5
- https://lists.debian.org/debian-lts-announce/2018/05/msg00000.html
- https://secuniaresearch.flexerasoftware.com/advisories/80454/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2017-20/
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
- https://usn.ubuntu.com/3754-1/
- https://www.debian.org/security/2018/dsa-4187
- https://www.spinics.net/lists/linux-usb/msg163480.html
Get alerted when CVE-2017-16911 or the next vulnerability affects your stack