What’s Vulnerable › Vulnerabilities
CVE-2017-16912
- Severity: medium (CVSS 5.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-31 · updated 2026-06-17
- Weakness: CWE-125
Description
The "get_pipe()" function (drivers/usb/usbip/stub_rx.c) in the Linux Kernel before version 4.14.8, 4.9.71, and 4.4.114 allows attackers to cause a denial of service (out-of-bounds read) via a specially crafted USB over IP packet.
Affected products
- Linux kernel: from 4.1.0 before 4.1.49; from 4.4.0 through 4.4.107; from 4.9.0 through 4.9.71; from 4.14.0 through 4.14.8 — fixed in 4.1.49
How to fix
Upgrade to a fixed version: Linux kernel 4.1.49. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102150
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.8
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.4.114
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.9.71
- https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/commit/drivers/usb/usbip?id=635f545a7e8be7596b9b2b6a43cab6bbd5a88e43
- https://lists.debian.org/debian-lts-announce/2018/05/msg00000.html
- https://secuniaresearch.flexerasoftware.com/advisories/77000/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2017-21/
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
- https://usn.ubuntu.com/3754-1/
- https://www.debian.org/security/2018/dsa-4187
Get alerted when CVE-2017-16912 or the next vulnerability affects your stack