What’s Vulnerable › Vulnerabilities
CVE-2017-16935
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-11-24 · updated 2026-06-17
- Weakness: CWE-20
Description
Ametys before 4.0.3 requires authentication only for URIs containing a /cms/ substring, which allows remote attackers to bypass intended access restrictions via a direct request to /plugins/core-ui/servercomm/messages.xml, as demonstrated by changing the admin password by obtaining account details via a users/search.json request, and then modifying the account via an editUser request.
Affected products
- Ametys CMS: before 4.0.3 — fixed in 4.0.3
How to fix
Upgrade to a fixed version: Ametys CMS 4.0.3. Check the vendor advisory for mitigations.
References
- https://blogs.securiteam.com/index.php/archives/3517
- https://issues.ametys.org/browse/RUNTIME-2582
- https://blogs.securiteam.com/index.php/archives/3517
- https://issues.ametys.org/browse/RUNTIME-2582
Get alerted when CVE-2017-16935 or the next vulnerability affects your stack