What’s Vulnerable › Vulnerabilities
CVE-2017-17068
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-06 · updated 2026-06-17
- Weakness: CWE-200
Description
A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().
Affected products
- auth0.js: before 8.12 — fixed in 8.12
How to fix
Upgrade to a fixed version: auth0.js 8.12. Check the vendor advisory for mitigations.
References
- https://appcheck-ng.com/appcheck-discovers-vulnerability-auth0-library-cve-2017-17068/
- https://auth0.com/docs/security/bulletins/cve-2017-17068
- https://appcheck-ng.com/appcheck-discovers-vulnerability-auth0-library-cve-2017-17068/
- https://auth0.com/docs/security/bulletins/cve-2017-17068
Get alerted when CVE-2017-17068 or the next vulnerability affects your stack