What’s Vulnerable › Vulnerabilities
CVE-2017-17092
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-02 · updated 2026-06-17
- Weakness: CWE-79
Description
wp-includes/functions.php in WordPress before 4.9.1 does not require the unfiltered_html capability for upload of .js files, which might allow remote attackers to conduct XSS attacks via a crafted file.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- WordPress: before 4.9.1 — fixed in 4.9.1
How to fix
Upgrade to a fixed version: WordPress 4.9.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102024
- https://codex.wordpress.org/Version_4.9.1
- https://github.com/WordPress/WordPress/commit/67d03a98c2cae5f41843c897f206adde299b0509
- https://lists.debian.org/debian-lts-announce/2017/12/msg00019.html
- https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/
- https://wpvulndb.com/vulnerabilities/8966
- https://www.debian.org/security/2018/dsa-4090
- http://www.securityfocus.com/bid/102024
- https://codex.wordpress.org/Version_4.9.1
- https://github.com/WordPress/WordPress/commit/67d03a98c2cae5f41843c897f206adde299b0509
- https://lists.debian.org/debian-lts-announce/2017/12/msg00019.html
- https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/
Get alerted when CVE-2017-17092 or the next vulnerability affects your stack