What’s Vulnerable › Vulnerabilities
CVE-2017-1724
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-26 · updated 2026-06-17
- Weakness: CWE-79
Description
IBM Security QRadar SIEM 7.2 and 7.3 is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session. IBM X-Force ID: 134814.
Affected products
- IBM QRadar Incident Forensics: from 7.2.0 before 7.2.8; 7.2.8, 7.2.8-p1, 7.2.8-p10, 7.2.8-p11, 7.2.8-p2, 7.2.8-p3 (+10) — fixed in 7.2.8
- IBM Qradar Network Insights: from 7.2.0 before 7.2.8; 7.2.8, 7.2.8-p1, 7.2.8-p10, 7.2.8-p11, 7.2.8-p2, 7.2.8-p3 (+10) — fixed in 7.2.8
- IBM Qradar Risk Manager: from 7.2.0 before 7.2.8; 7.2.8, 7.2.8-p1, 7.2.8-p10, 7.2.8-p11, 7.2.8-p2, 7.2.8-p3 (+10) — fixed in 7.2.8
- IBM QRadar SIEM: from 7.2.0 before 7.2.8; 7.2.8, 7.2.8-p1, 7.2.8-p10, 7.2.8-p11, 7.2.8-p2, 7.2.8-p3 (+10) — fixed in 7.2.8
- IBM Qradar Vulnerability Manager: from 7.2.0 before 7.2.8; 7.2.8, 7.2.8-p1, 7.2.8-p10, 7.2.8-p11, 7.2.8-p2, 7.2.8-p3 (+10) — fixed in 7.2.8
How to fix
Upgrade to a fixed version: IBM QRadar Incident Forensics 7.2.8; IBM Qradar Network Insights 7.2.8; IBM Qradar Risk Manager 7.2.8; IBM QRadar SIEM 7.2.8; IBM Qradar Vulnerability Manager 7.2.8. Check the vendor advisory for mitigations.
References
- http://www.ibm.com/support/docview.wss?uid=swg22015807
- https://exchange.xforce.ibmcloud.com/vulnerabilities/134814
- http://www.ibm.com/support/docview.wss?uid=swg22015807
- https://exchange.xforce.ibmcloud.com/vulnerabilities/134814
Get alerted when CVE-2017-1724 or the next vulnerability affects your stack