What’s Vulnerable › Vulnerabilities
CVE-2017-17411
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 87.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-21 · updated 2026-06-17
- Weakness: CWE-78
Description
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Linksys WVBR0. Authentication is not required to exploit this vulnerability. The specific flaw exists within the web management portal. The issue lies in the lack of proper validation of user data before executing a system call. An attacker could leverage this vulnerability to execute code with root privileges. Was ZDI-CAN-4892.
Affected products
- Linksys WVBR0: before 1.0.41 — fixed in 1.0.41
How to fix
Upgrade to a fixed version: Linksys WVBR0 1.0.41. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102212
- https://github.com/rapid7/metasploit-framework/pull/9336
- https://www.exploit-db.com/exploits/43363/
- https://www.exploit-db.com/exploits/43429/
- https://zerodayinitiative.com/advisories/ZDI-17-973
- http://www.securityfocus.com/bid/102212
- https://github.com/rapid7/metasploit-framework/pull/9336
- https://www.exploit-db.com/exploits/43363/
- https://www.exploit-db.com/exploits/43429/
- https://zerodayinitiative.com/advisories/ZDI-17-973
Get alerted when CVE-2017-17411 or the next vulnerability affects your stack