What’s Vulnerable › Vulnerabilities
CVE-2017-17451
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Mailster plugin before 1.5.5 for WordPress has XSS in the unsubscribe handler via the mes parameter to view/subscription/unsubscribe2.php.
Affected products
- brandtoss WP Mailster: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: brandtoss WP Mailster 1.5.5. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/145222/WordPress-WP-Mailster-1.5.4.0-Cross-Site-Scripting.html
- https://wordpress.org/plugins/wp-mailster/#developers
- https://wpvulndb.com/vulnerabilities/8973
- https://packetstormsecurity.com/files/145222/WordPress-WP-Mailster-1.5.4.0-Cross-Site-Scripting.html
- https://wordpress.org/plugins/wp-mailster/#developers
- https://wpvulndb.com/vulnerabilities/8973
Get alerted when CVE-2017-17451 or the next vulnerability affects your stack