What’s Vulnerable › Vulnerabilities
CVE-2017-17458
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-07 · updated 2026-06-17
- Weakness: CWE-78
Description
In Mercurial before 4.4.1, it is possible that a specially malformed repository can cause Git subrepositories to run arbitrary code in the form of a .git/hooks/post-update script checked into the repository. Typical use of Mercurial prevents construction of such repositories, but they can be created programmatically.
Affected products
- Debian Linux: 7.0, 8.0
- mercurial: before 4.4.1 — fixed in 4.4.1
How to fix
Upgrade to a fixed version: mercurial 4.4.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102926
- https://bz.mercurial-scm.org/show_bug.cgi?id=5730
- https://confluence.atlassian.com/sourcetreekb/sourcetree-security-advisory-2018-01-24-942834324.html
- https://lists.debian.org/debian-lts-announce/2017/12/msg00027.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00041.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html
- https://www.mercurial-scm.org/pipermail/mercurial-devel/2017-November/107333.html
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.4.1_.282017-11-07.29
- http://www.securityfocus.com/bid/102926
- https://bz.mercurial-scm.org/show_bug.cgi?id=5730
- https://confluence.atlassian.com/sourcetreekb/sourcetree-security-advisory-2018-01-24-942834324.html
Get alerted when CVE-2017-17458 or the next vulnerability affects your stack