What’s Vulnerable › Vulnerabilities
CVE-2017-17499
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-11 · updated 2026-06-17
- Weakness: CWE-416
Description
ImageMagick before 6.9.9-24 and 7.x before 7.0.7-12 has a use-after-free in Magick::Image::read in Magick++/lib/Image.cpp.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 9.0
- ImageMagick: from 7.0.0-0 before 7.0.7-12; before 6.9.9-24 — fixed in 6.9.9-24, 7.0.7-12
How to fix
Upgrade to a fixed version: ImageMagick 6.9.9-24, 7.0.7-12. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/102155
- https://github.com/ImageMagick/ImageMagick/commit/8c35502217c1879cb8257c617007282eee3fe1cc
- https://github.com/ImageMagick/ImageMagick/commit/dd96d671e4d5ae22c6894c302e8996c13f24c45a
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4074
- https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=33078&sid=5fbb164c3830293138917f9b14264ed1
- http://www.securityfocus.com/bid/102155
- https://github.com/ImageMagick/ImageMagick/commit/8c35502217c1879cb8257c617007282eee3fe1cc
- https://github.com/ImageMagick/ImageMagick/commit/dd96d671e4d5ae22c6894c302e8996c13f24c45a
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4074
- https://www.imagemagick.org/discourse-server/viewtopic.php?f=3&t=33078&sid=5fbb164c3830293138917f9b14264ed1
Get alerted when CVE-2017-17499 or the next vulnerability affects your stack