What’s Vulnerable › Vulnerabilities
CVE-2017-17504
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-11 · updated 2026-06-17
- Weakness: CWE-125
Description
ImageMagick before 7.0.7-12 has a coders/png.c Magick_png_read_raw_profile heap-based buffer over-read via a crafted file, related to ReadOneMNGImage.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- ImageMagick: before 6.9.9-24; from 7.0.0-0 before 7.0.7-12 — fixed in 6.9.9-24, 7.0.7-12
How to fix
Upgrade to a fixed version: ImageMagick 6.9.9-24, 7.0.7-12. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/issues/872
- https://lists.debian.org/debian-lts-announce/2018/01/msg00000.html
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4074
- https://www.debian.org/security/2018/dsa-4204
- https://github.com/ImageMagick/ImageMagick/issues/872
- https://lists.debian.org/debian-lts-announce/2018/01/msg00000.html
- https://usn.ubuntu.com/3681-1/
- https://www.debian.org/security/2017/dsa-4074
- https://www.debian.org/security/2018/dsa-4204
Get alerted when CVE-2017-17504 or the next vulnerability affects your stack