What’s Vulnerable › Vulnerabilities
CVE-2017-17512
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-11 · updated 2026-10-14
- Weakness: CWE-74
Description
sensible-browser in sensible-utils before 0.0.11 does not validate strings before launching the program specified by the BROWSER environment variable, which allows remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by a --proxy-pac-file argument.
Affected products
- Sensible-Utils Project Sensible-Utils: before 0.0.11 — fixed in 0.0.11
How to fix
Upgrade to a fixed version: Sensible-Utils Project Sensible-Utils 0.0.11. Check the vendor advisory for mitigations.
References
- http://metadata.ftp-master.debian.org/changelogs/main/s/sensible-utils/sensible-utils_0.0.11_changelog
- https://bugs.debian.org/881767
- https://lists.debian.org/debian-lts-announce/2017/12/msg00012.html
- https://usn.ubuntu.com/3584-1/
- https://www.debian.org/security/2017/dsa-4071
- http://metadata.ftp-master.debian.org/changelogs/main/s/sensible-utils/sensible-utils_0.0.11_changelog
- https://bugs.debian.org/881767
- https://lists.debian.org/debian-lts-announce/2017/12/msg00012.html
- https://usn.ubuntu.com/3584-1/
- https://www.debian.org/security/2017/dsa-4071
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2017-17512 or the next vulnerability affects your stack