What’s Vulnerable › Vulnerabilities
CVE-2017-17557
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-24 · updated 2026-06-17
- Weakness: CWE-119
Description
In Foxit Reader before 9.1 and Foxit PhantomPDF before 9.1, a flaw exists within the parsing of the BITMAPINFOHEADER record in BMP files. The issue results from the lack of proper validation of the biSize member, which can result in a heap based buffer overflow. An attacker can leverage this to execute code in the context of the current process.
Affected products
- Foxit Reader: before 9.1 — fixed in 9.1
- Foxit PhantomPDF: before 9.1 — fixed in 9.1
How to fix
Upgrade to a fixed version: Foxit Reader 9.1; Foxit PhantomPDF 9.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103999
- http://www.securitytracker.com/id/1040733
- https://blog.0patch.com/2018/05/0patching-foxit-reader-buffer-oops.html
- https://www.foxitsoftware.com/support/security-bulletins.php
- http://www.securityfocus.com/bid/103999
- http://www.securitytracker.com/id/1040733
- https://blog.0patch.com/2018/05/0patching-foxit-reader-buffer-oops.html
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2017-17557 or the next vulnerability affects your stack