What’s Vulnerable › Vulnerabilities
CVE-2017-17562: Embedthis GoAhead Remote Code Execution Vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-12-10
- EPSS: 97.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2017-12-12 · updated 2026-06-17
Description
Embedthis GoAhead before 3.6.5 allows remote code execution if CGI is enabled and a CGI program is dynamically linked. This is a result of initializing the environment of forked CGI scripts using untrusted HTTP request parameters in the cgiHandler function in cgi.c. When combined with the glibc dynamic linker, this behaviour can be abused for remote code execution using special parameter names such as LD_PRELOAD. An attacker can POST their shared object payload in the body of the request, and reference it using /proc/self/fd/0.
Affected products
- EmbedThis GoAhead: before 3.6.5 — fixed in 3.6.5
- Oracle Integrated Lights Out Manager: 3.0, 4.0
How to fix
Upgrade to a fixed version: EmbedThis GoAhead 3.6.5. Check the vendor advisory for mitigations.
References
- http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
- http://www.securitytracker.com/id/1040702
- https://github.com/elttam/advisories/tree/master/CVE-2017-17562
- https://github.com/embedthis/goahead/commit/6f786c123196eb622625a920d54048629a7caa74
- https://github.com/embedthis/goahead/issues/249
- https://www.elttam.com.au/blog/goahead/
- https://www.exploit-db.com/exploits/43360/
- https://www.exploit-db.com/exploits/43877/
- http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
- http://www.securitytracker.com/id/1040702
- https://github.com/elttam/advisories/tree/master/CVE-2017-17562
- https://github.com/embedthis/goahead/commit/6f786c123196eb622625a920d54048629a7caa74
Get alerted when CVE-2017-17562 or the next vulnerability affects your stack