What’s Vulnerable › Vulnerabilities
CVE-2017-17663
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-06 · updated 2026-06-17
- Weakness: CWE-119
Description
The htpasswd implementation of mini_httpd before v1.28 and of thttpd before v2.28 is affected by a buffer overflow that can be exploited remotely to perform code execution.
Affected products
- ACME Mini Httpd: before 1.28 — fixed in 1.28
- thttpd: before 2.28 — fixed in 2.28
How to fix
Upgrade to a fixed version: ACME Mini Httpd 1.28; thttpd 2.28. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-17663 or the next vulnerability affects your stack