What’s Vulnerable › Vulnerabilities
CVE-2017-17665
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-13 · updated 2026-06-17
- Weakness: CWE-862
Description
In Octopus Deploy before 4.1.3, the machine update process doesn't check that the user has access to all environments. This allows an access-control bypass because the set of environments to which a machine is scoped may include environments in which the user lacks access.
Affected products
- Octopus Deploy: before 4.1.3 — fixed in 4.1.3
How to fix
Upgrade to a fixed version: Octopus Deploy 4.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/OctopusDeploy/Issues/issues/4073
- https://github.com/OctopusDeploy/Issues/issues/4073
Get alerted when CVE-2017-17665 or the next vulnerability affects your stack