What’s Vulnerable › Vulnerabilities
CVE-2017-17809
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2017-12-20 · updated 2026-06-17
- Weakness: CWE-426
Description
In Golden Frog VyprVPN before 2.15.0.5828 for macOS, the vyprvpnservice launch daemon has an unprotected XPC service that allows attackers to update the underlying OpenVPN configuration and the arguments passed to the OpenVPN binary when executed. An attacker can abuse this vulnerability by forcing the VyprVPN application to load a malicious dynamic library every time a new connection is made.
Affected products
- Goldenfrog Vyprvpn: before 2.15.0.5828 — fixed in 2.15.0.5828
How to fix
Upgrade to a fixed version: Goldenfrog Vyprvpn 2.15.0.5828. Check the vendor advisory for mitigations.
References
- https://github.com/VerSprite/research/blob/master/advisories/VS-2017-007.md
- https://github.com/VerSprite/research/blob/master/advisories/VS-2017-007.md
Get alerted when CVE-2017-17809 or the next vulnerability affects your stack