What’s Vulnerable › Vulnerabilities
CVE-2017-17947
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross site scripting issue has been found in custompage.cgi in Pulse Secure Pulse Connect Secure (PCS) before 8.0R17.0, 8.1.x before 8.1R13, 8.2.x before 8.2R9, and 8.3.x before 8.3R3 and Pulse Policy Secure (PPS) before 5.2R10, 5.3.x before 5.3R9, and 5.4.x before 5.4R3 due to one of the URL parameters not being sanitized. Exploitation does require the user to be logged in as administrator; the issue is not applicable to the end user portal.
Affected products
- Ivanti Connect Secure (Pulse Secure): before 8.0r17.0; from 8.1 before 8.1r13; from 8.2 through 8.2r9; from 8.3 before 8.3r3 — fixed in 8.0r17.0, 8.1r13, 8.3r3
How to fix
Upgrade to a fixed version: Ivanti Connect Secure (Pulse Secure) 8.0r17.0, 8.1r13, 8.3r3. Check the vendor advisory for mitigations.
References
- http://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA43018
- http://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA43018
Get alerted when CVE-2017-17947 or the next vulnerability affects your stack