What’s Vulnerable › Vulnerabilities
CVE-2017-17969
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-30 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based buffer overflow in the NCompress::NShrink::CDecoder::CodeReal method in 7-Zip before 18.00 and p7zip allows remote attackers to cause a denial of service (out-of-bounds write) or potentially execute arbitrary code via a crafted ZIP archive.
Affected products
- 7-Zip: before 18.00 — fixed in 18.00
- 7-Zip P7Zip: before 18.0 — fixed in 18.0
- Debian Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: 7-Zip 18.00; 7-Zip P7Zip 18.0. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1040831
- https://0patch.blogspot.si/2018/02/two-interesting-micropatches-for-7-zip.html
- https://github.com/p7zip-project/p7zip/issues/7
- https://landave.io/2018/01/7-zip-multiple-memory-corruptions-via-rar-and-zip/
- https://lists.debian.org/debian-lts-announce/2018/02/msg00003.html
- https://usn.ubuntu.com/3913-1/
- https://www.debian.org/security/2018/dsa-4104
- http://www.securitytracker.com/id/1040831
- https://0patch.blogspot.si/2018/02/two-interesting-micropatches-for-7-zip.html
- https://landave.io/2018/01/7-zip-multiple-memory-corruptions-via-rar-and-zip/
- https://lists.debian.org/debian-lts-announce/2018/02/msg00003.html
- https://usn.ubuntu.com/3913-1/
Get alerted when CVE-2017-17969 or the next vulnerability affects your stack