What’s Vulnerable › Vulnerabilities
CVE-2017-18015
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The ILLID Share This Image plugin before 1.04 for WordPress has XSS via the sharer.php url parameter.
Affected products
- Wp-Unit Share This Image: before 1.04 — fixed in 1.04
How to fix
Upgrade to a fixed version: Wp-Unit Share This Image 1.04. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/145464/WordPress-Share-This-Image-1.03-Cross-Site-Scripting.html
- https://wordpress.org/plugins/share-this-image/#developers
- https://wordpress.org/support/topic/share-this-image-1-03-cross-site-scripting/
- https://wpvulndb.com/vulnerabilities/8991
- https://packetstormsecurity.com/files/145464/WordPress-Share-This-Image-1.03-Cross-Site-Scripting.html
- https://wordpress.org/plugins/share-this-image/#developers
- https://wordpress.org/support/topic/share-this-image-1-03-cross-site-scripting/
- https://wpvulndb.com/vulnerabilities/8991
Get alerted when CVE-2017-18015 or the next vulnerability affects your stack