What’s Vulnerable › Vulnerabilities
CVE-2017-18017
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 52.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-03 · updated 2026-06-17
- Weakness: CWE-416
Description
The tcpmss_mangle_packet function in net/netfilter/xt_TCPMSS.c in the Linux kernel before 4.11, and 4.9.x before 4.9.36, allows remote attackers to cause a denial of service (use-after-free and memory corruption) or possibly have unspecified other impact by leveraging the presence of xt_TCPMSS in an iptables action.
Affected products
- Arista Networks EOS: 4.20.1fx-virtual-router
- Canonical Ubuntu Linux: 12.04, 14.04
- Debian Linux: 7.0, 8.0
- F5 Arx: from 6.2.0 through 6.4.0
- Linux kernel: from 3.2 before 3.2.99; from 3.3 before 3.10.108; from 3.11 before 3.16.54; from 3.17 before 3.18.60; from 3.19 before 4.1.43; from 4.2 before 4.4.76 — fixed in 3.10.108, 3.16.54, 3.18.60, 3.2.99, 4.1.43, 4.11
- OpenStack Cloud Magnum Orchestration: 7
- openSUSE Leap: 42.3
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Eus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux For Real Time: 7
- RedHat Enterprise Linux For Real Time For Nfv: 7
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Server Tus: 7.3, 7.4, 7.6, 7.7
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- RedHat Mrg Realtime: 2.0
- SUSE CaaS Platform 4.5: all versions
- SUSE Linux Enterprise Debuginfo: 11-sp3, 11-sp4
- SUSE Linux Enterprise Server 15 SP1: 12-sp2, 12-sp3
- SUSE Linux Enterprise High Availability: 12-sp2, 12-sp3
- SUSE Linux Enterprise High Availability Extension: 11-sp4
- SUSE Linux Enterprise Live Patching: 12, 12-sp3
- SUSE Linux Enterprise Module For Public Cloud: 12
- SUSE Linux Enterprise Point Of Sale: 11-sp3
- SUSE Linux Enterprise Real Time Extension: 11-sp4, 12-sp2, 12-sp3
- SUSE Linux Enterprise Server: 11-sp3, 11-sp4, 12, 12-sp1, 12-sp2, 12-sp3
- SUSE Linux Enterprise Software Development Kit: 11-sp4, 12-sp2, 12-sp3
- SUSE Linux Enterprise Workstation Extension: 12-sp2, 12-sp3
- SUSE Openstack Cloud: 6
How to fix
Upgrade to a fixed version: Linux kernel 3.10.108, 3.16.54, 3.18.60, 3.2.99. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=2638fd0f92d4397884fd991d8f4925cb3f081901
- http://lists.opensuse.org/opensuse-security-announce/2018-02/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2018-02/msg00013.html
- http://lists.opensuse.org/opensuse-security-announce/2018-02/msg00015.html
- http://lists.opensuse.org/opensuse-security-announce/2018-02/msg00038.html
- http://lists.opensuse.org/opensuse-security-announce/2018-02/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2018-03/msg00030.html
- http://lists.opensuse.org/opensuse-security-announce/2018-03/msg00067.html
- http://lists.opensuse.org/opensuse-security-announce/2018-03/msg00070.html
- http://lists.opensuse.org/opensuse-security-announce/2018-03/msg00072.html
- http://lists.opensuse.org/opensuse-security-announce/2018-04/msg00014.html
- http://patchwork.ozlabs.org/patch/746618/
Get alerted when CVE-2017-18017 or the next vulnerability affects your stack