What’s Vulnerable › Vulnerabilities

CVE-2017-18026

Description

Redmine before 3.2.9, 3.3.x before 3.3.6, and 3.4.x before 3.4.4 does not block the --config and --debugger flags to the Mercurial hg program, which allows remote attackers to execute arbitrary commands (through the Mercurial adapter) via vectors involving a branch whose name begins with a --config= or --debugger= substring, a related issue to CVE-2017-17536.

Affected products

How to fix

Upgrade to a fixed version: Redmine 3.2.9, 3.3.6, 3.4.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-18026 or the next vulnerability affects your stack