What’s Vulnerable › Vulnerabilities
CVE-2017-18075
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-24 · updated 2026-06-17
- Weakness: CWE-763
Description
crypto/pcrypt.c in the Linux kernel before 4.14.13 mishandles freeing instances, allowing a local user able to access the AF_ALG-based AEAD interface (CONFIG_CRYPTO_USER_API_AEAD) and pcrypt (CONFIG_CRYPTO_PCRYPT) to cause a denial of service (kfree of an incorrect pointer) or possibly have unspecified other impact by executing a crafted sequence of system calls.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Linux kernel: from 4.2 before 4.4.111; from 4.5 before 4.9.76; from 4.10 before 4.14.13 — fixed in 4.14.13, 4.4.111, 4.9.76
How to fix
Upgrade to a fixed version: Linux kernel 4.14.13, 4.4.111, 4.9.76. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d76c68109f37cb85b243a1cf0f40313afd2bae68
- http://www.securityfocus.com/bid/102813
- https://access.redhat.com/errata/RHSA-2018:2948
- https://github.com/torvalds/linux/commit/d76c68109f37cb85b243a1cf0f40313afd2bae68
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
- https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.14.13
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d76c68109f37cb85b243a1cf0f40313afd2bae68
- http://www.securityfocus.com/bid/102813
- https://access.redhat.com/errata/RHSA-2018:2948
- https://github.com/torvalds/linux/commit/d76c68109f37cb85b243a1cf0f40313afd2bae68
- https://usn.ubuntu.com/3619-1/
Get alerted when CVE-2017-18075 or the next vulnerability affects your stack