What’s Vulnerable › Vulnerabilities
CVE-2017-18076
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-26 · updated 2026-06-17
Description
In strategy.rb in OmniAuth before 1.3.2, the authenticity_token value is improperly protected because POST (in addition to GET) parameters are stored in the session and become available in the environment of the callback phase.
Affected products
- Debian Linux: 8.0, 9.0
- omniauth ruby gem: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: omniauth ruby gem 1.3.2. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/888523
- https://github.com/omniauth/omniauth/pull/867
- https://github.com/omniauth/omniauth/pull/867/commits/71866c5264122e196847a3980c43051446a03e9b
- https://www.debian.org/security/2018/dsa-4109
- https://bugs.debian.org/888523
- https://github.com/omniauth/omniauth/pull/867
- https://github.com/omniauth/omniauth/pull/867/commits/71866c5264122e196847a3980c43051446a03e9b
- https://www.debian.org/security/2018/dsa-4109
Get alerted when CVE-2017-18076 or the next vulnerability affects your stack