What’s Vulnerable › Vulnerabilities
CVE-2017-18084
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The usermacros resource in Atlassian Confluence Server before version 6.3.4 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the description of a macro.
Affected products
- Atlassian Confluence: before 6.3.4 — fixed in 6.3.4
How to fix
Upgrade to a fixed version: Atlassian Confluence 6.3.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103064
- https://jira.atlassian.com/browse/CONFSERVER-54904
- http://www.securityfocus.com/bid/103064
- https://jira.atlassian.com/browse/CONFSERVER-54904
Get alerted when CVE-2017-18084 or the next vulnerability affects your stack