What’s Vulnerable › Vulnerabilities
CVE-2017-18085
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The viewdefaultdecorator resource in Atlassian Confluence Server before version 6.6.1 allows remote attackers to inject arbitrary HTML or JavaScript via a cross site scripting (XSS) vulnerability through the key parameter.
Affected products
- Atlassian Confluence: before 6.6.1 — fixed in 6.6.1
How to fix
Upgrade to a fixed version: Atlassian Confluence 6.6.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103062
- https://jira.atlassian.com/browse/CONFSERVER-54905
- http://www.securityfocus.com/bid/103062
- https://jira.atlassian.com/browse/CONFSERVER-54905
Get alerted when CVE-2017-18085 or the next vulnerability affects your stack