What’s Vulnerable › Vulnerabilities
CVE-2017-18111
- Severity: high (CVSS 8.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-29 · updated 2026-06-17
- Weakness: CWE-611
Description
The OAuthHelper in Atlassian Application Links before version 5.0.10, from version 5.1.0 before version 5.1.3, and from version 5.2.0 before version 5.2.6 used an XML document builder that was vulnerable to XXE when consuming a client OAuth request. This allowed malicious oauth application linked applications to probe internal network resources by requesting internal locations, read the contents of files and also cause an out of memory exception affecting availability via an XML External Entity vulnerability.
Affected products
- Atlassian Application Links: before 5.0.10; from 5.1.0 before 5.1.3; from 5.2.0 before 5.2.6 — fixed in 5.0.10, 5.1.3, 5.2.6
How to fix
Upgrade to a fixed version: Atlassian Application Links 5.0.10, 5.1.3, 5.2.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2017-18111 or the next vulnerability affects your stack