What’s Vulnerable › Vulnerabilities
CVE-2017-18184
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-13 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
Affected products
- Qpdf Project Qpdf: before 7.0.0 — fixed in 7.0.0
How to fix
Upgrade to a fixed version: Qpdf Project Qpdf 7.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/qpdf/qpdf/commit/dea704f0ab7f625e1e7b3f9a1110b45b63157317
- https://github.com/qpdf/qpdf/issues/147
- https://usn.ubuntu.com/3638-1/
- https://github.com/qpdf/qpdf/commit/dea704f0ab7f625e1e7b3f9a1110b45b63157317
- https://github.com/qpdf/qpdf/issues/147
- https://usn.ubuntu.com/3638-1/
Get alerted when CVE-2017-18184 or the next vulnerability affects your stack