What’s Vulnerable › Vulnerabilities
CVE-2017-18187
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-14 · updated 2026-06-17
- Weakness: CWE-190
Description
In ARM mbed TLS before 2.7.0, there is a bounds-check bypass through an integer overflow in PSK identity parsing in the ssl_parse_client_psk_identity() function in library/ssl_srv.c.
Affected products
- mbedtls: before 2.7.0 — fixed in 2.7.0
- Debian Linux: 8.0, 9.0
How to fix
Upgrade to a fixed version: mbedtls 2.7.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103055
- https://github.com/ARMmbed/mbedtls/blob/master/ChangeLog
- https://github.com/ARMmbed/mbedtls/commit/83c9f495ffe70c7dd280b41fdfd4881485a3bc28
- https://security.gentoo.org/glsa/201804-19
- https://usn.ubuntu.com/4267-1/
- https://www.debian.org/security/2018/dsa-4138
- https://www.debian.org/security/2018/dsa-4147
- http://www.securityfocus.com/bid/103055
- https://github.com/ARMmbed/mbedtls/blob/master/ChangeLog
- https://github.com/ARMmbed/mbedtls/commit/83c9f495ffe70c7dd280b41fdfd4881485a3bc28
- https://security.gentoo.org/glsa/201804-19
- https://usn.ubuntu.com/4267-1/
Get alerted when CVE-2017-18187 or the next vulnerability affects your stack