What’s Vulnerable › Vulnerabilities
CVE-2017-18198
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-24 · updated 2026-06-17
- Weakness: CWE-125
Description
print_iso9660_recurse in iso-info.c in GNU libcdio before 1.0.0 allows remote attackers to cause a denial of service (heap-based buffer over-read) or possibly have unspecified other impact via a crafted iso file.
Affected products
- GNU Libcdio: before 1.0.0 — fixed in 1.0.0
How to fix
Upgrade to a fixed version: GNU Libcdio 1.0.0. Check the vendor advisory for mitigations.
References
- http://ftp.gnu.org/gnu/libcdio/libcdio-1.0.0.tar.gz
- http://www.securityfocus.com/bid/103200
- https://access.redhat.com/errata/RHSA-2018:3246
- https://savannah.gnu.org/bugs/?52265
- http://ftp.gnu.org/gnu/libcdio/libcdio-1.0.0.tar.gz
- http://www.securityfocus.com/bid/103200
- https://access.redhat.com/errata/RHSA-2018:3246
- https://savannah.gnu.org/bugs/?52265
Get alerted when CVE-2017-18198 or the next vulnerability affects your stack