What’s Vulnerable › Vulnerabilities
CVE-2017-18201
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-26 · updated 2026-06-17
- Weakness: CWE-415
Description
An issue was discovered in GNU libcdio before 2.0.0. There is a double free in get_cdtext_generic() in lib/driver/_cdio_generic.c.
Affected products
- GNU Libcdio: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: GNU Libcdio 2.0.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103190
- https://access.redhat.com/errata/RHSA-2018:3246
- https://git.savannah.gnu.org/cgit/libcdio.git/commit/?id=f6f9c48fb40b8a1e8218799724b0b61a7161eb1d
- http://www.securityfocus.com/bid/103190
- https://access.redhat.com/errata/RHSA-2018:3246
- https://git.savannah.gnu.org/cgit/libcdio.git/commit/?id=f6f9c48fb40b8a1e8218799724b0b61a7161eb1d
Get alerted when CVE-2017-18201 or the next vulnerability affects your stack