What’s Vulnerable › Vulnerabilities
CVE-2017-18206
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-27 · updated 2026-06-17
- Weakness: CWE-119
Description
In utils.c in zsh before 5.4, symlink expansion had a buffer overflow.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- zsh: before 5.4 — fixed in 5.4
How to fix
Upgrade to a fixed version: zsh 5.4. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:1932
- https://access.redhat.com/errata/RHSA-2018:3073
- https://lists.debian.org/debian-lts-announce/2020/12/msg00000.html
- https://security.gentoo.org/glsa/201805-10
- https://sourceforge.net/p/zsh/code/ci/c7a9cf465dd620ef48d586026944d9bd7a0d5d6d
- https://usn.ubuntu.com/3593-1/
- https://access.redhat.com/errata/RHSA-2018:1932
- https://access.redhat.com/errata/RHSA-2018:3073
- https://lists.debian.org/debian-lts-announce/2020/12/msg00000.html
- https://security.gentoo.org/glsa/201805-10
- https://sourceforge.net/p/zsh/code/ci/c7a9cf465dd620ef48d586026944d9bd7a0d5d6d
- https://usn.ubuntu.com/3593-1/
Get alerted when CVE-2017-18206 or the next vulnerability affects your stack