What’s Vulnerable › Vulnerabilities
CVE-2017-18217
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in InvoicePlane before 1.5.5. It was observed that the Email address and Web address parameters are vulnerable to Cross Site Scripting, related to application/modules/clients/views/view.php, application/modules/invoices/views/view.php, and application/modules/quotes/views/view.php.
Affected products
- InvoicePlane: before 1.5.5 — fixed in 1.5.5
How to fix
Upgrade to a fixed version: InvoicePlane 1.5.5. Check the vendor advisory for mitigations.
References
- http://blog.isecurion.com/2018/04/23/invoice-plane-v1-5-cross-site-scripting-vulnerability/
- https://github.com/InvoicePlane/InvoicePlane/pull/542
- https://github.com/InvoicePlane/InvoicePlane/pull/551
- http://blog.isecurion.com/2018/04/23/invoice-plane-v1-5-cross-site-scripting-vulnerability/
- https://github.com/InvoicePlane/InvoicePlane/pull/542
- https://github.com/InvoicePlane/InvoicePlane/pull/551
Get alerted when CVE-2017-18217 or the next vulnerability affects your stack