What’s Vulnerable › Vulnerabilities
CVE-2017-18218
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-05 · updated 2026-06-17
- Weakness: CWE-416
Description
In drivers/net/ethernet/hisilicon/hns/hns_enet.c in the Linux kernel before 4.13, local users can cause a denial of service (use-after-free and BUG) or possibly have unspecified other impact by leveraging differences in skb handling between hns_nic_net_xmit_hw and hns_nic_net_xmit.
Affected products
- Linux kernel: from 4.5 before 4.9.92; from 4.10 before 4.13 — fixed in 4.13, 4.9.92
How to fix
Upgrade to a fixed version: Linux kernel 4.13, 4.9.92. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=27463ad99f738ed93c7c8b3e2e5bc8c4853a2ff2
- http://www.securityfocus.com/bid/103277
- https://github.com/torvalds/linux/commit/27463ad99f738ed93c7c8b3e2e5bc8c4853a2ff2
- https://www.debian.org/security/2018/dsa-4188
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=27463ad99f738ed93c7c8b3e2e5bc8c4853a2ff2
- http://www.securityfocus.com/bid/103277
- https://github.com/torvalds/linux/commit/27463ad99f738ed93c7c8b3e2e5bc8c4853a2ff2
- https://www.debian.org/security/2018/dsa-4188
Get alerted when CVE-2017-18218 or the next vulnerability affects your stack