What’s Vulnerable › Vulnerabilities
CVE-2017-18224
- Severity: medium (CVSS 4.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-12 · updated 2026-06-17
- Weakness: CWE-362
Description
In the Linux kernel before 4.15, fs/ocfs2/aops.c omits use of a semaphore and consequently has a race condition for access to the extent tree during read operations in DIRECT mode, which allows local users to cause a denial of service (BUG) by modifying a certain e_cpos field.
Affected products
- Linux kernel: before 4.15 — fixed in 4.15
How to fix
Upgrade to a fixed version: Linux kernel 4.15. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3e4c56d41eef5595035872a2ec5a483f42e8917f
- http://www.securityfocus.com/bid/103353
- https://github.com/torvalds/linux/commit/3e4c56d41eef5595035872a2ec5a483f42e8917f
- https://www.debian.org/security/2018/dsa-4188
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3e4c56d41eef5595035872a2ec5a483f42e8917f
- http://www.securityfocus.com/bid/103353
- https://github.com/torvalds/linux/commit/3e4c56d41eef5595035872a2ec5a483f42e8917f
- https://www.debian.org/security/2018/dsa-4188
Get alerted when CVE-2017-18224 or the next vulnerability affects your stack