What’s Vulnerable › Vulnerabilities
CVE-2017-18237
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-15 · updated 2026-06-17
- Weakness: CWE-476
Description
An issue was discovered in Exempi before 2.4.3. The PostScript_Support::ConvertToDate function in XMPFiles/source/FormatSupport/PostScript_Support.cpp allows remote attackers to cause a denial of service (invalid pointer dereference and application crash) via a crafted .ps file.
Affected products
- Exempi Project Exempi: before 2.4.3 — fixed in 2.4.3
How to fix
Upgrade to a fixed version: Exempi Project Exempi 2.4.3. Check the vendor advisory for mitigations.
References
- https://bugs.freedesktop.org/show_bug.cgi?id=101914
- https://cgit.freedesktop.org/exempi/commit/?id=f19d0107fbae1fb41836cd110d4425e407e64048
- https://bugs.freedesktop.org/show_bug.cgi?id=101914
- https://cgit.freedesktop.org/exempi/commit/?id=f19d0107fbae1fb41836cd110d4425e407e64048
Get alerted when CVE-2017-18237 or the next vulnerability affects your stack