What’s Vulnerable › Vulnerabilities
CVE-2017-18241
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-21 · updated 2026-06-17
- Weakness: CWE-476
Description
fs/f2fs/segment.c in the Linux kernel before 4.13 allows local users to cause a denial of service (NULL pointer dereference and panic) by using a noflush_merge option that triggers a NULL value for a flush_cmd_control data structure.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Debian Linux: 8.0, 9.0
- Linux kernel: before 4.13 — fixed in 4.13
How to fix
Upgrade to a fixed version: Linux kernel 4.13. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d4fdf8ba0e5808ba9ad6b44337783bd9935e0982
- https://github.com/torvalds/linux/commit/d4fdf8ba0e5808ba9ad6b44337783bd9935e0982
- https://usn.ubuntu.com/3910-1/
- https://usn.ubuntu.com/3910-2/
- https://www.debian.org/security/2018/dsa-4187
- https://www.debian.org/security/2018/dsa-4188
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d4fdf8ba0e5808ba9ad6b44337783bd9935e0982
- https://github.com/torvalds/linux/commit/d4fdf8ba0e5808ba9ad6b44337783bd9935e0982
- https://usn.ubuntu.com/3910-1/
- https://usn.ubuntu.com/3910-2/
- https://www.debian.org/security/2018/dsa-4187
- https://www.debian.org/security/2018/dsa-4188
Get alerted when CVE-2017-18241 or the next vulnerability affects your stack