What’s Vulnerable › Vulnerabilities
CVE-2017-18257
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-04 · updated 2026-06-17
- Weakness: CWE-190
Description
The __get_data_block function in fs/f2fs/data.c in the Linux kernel before 4.11 allows local users to cause a denial of service (integer overflow and loop) via crafted use of the open and fallocate system calls with an FS_IOC_FIEMAP ioctl.
Affected products
- Debian Linux: 9.0
- Linux kernel: before 4.11 — fixed in 4.11
How to fix
Upgrade to a fixed version: Linux kernel 4.11. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b86e33075ed1909d8002745b56ecf73b833db143
- https://github.com/torvalds/linux/commit/b86e33075ed1909d8002745b56ecf73b833db143
- https://usn.ubuntu.com/3696-1/
- https://usn.ubuntu.com/3696-2/
- https://www.debian.org/security/2018/dsa-4188
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b86e33075ed1909d8002745b56ecf73b833db143
- https://github.com/torvalds/linux/commit/b86e33075ed1909d8002745b56ecf73b833db143
- https://usn.ubuntu.com/3696-1/
- https://usn.ubuntu.com/3696-2/
- https://www.debian.org/security/2018/dsa-4188
Get alerted when CVE-2017-18257 or the next vulnerability affects your stack