What’s Vulnerable › Vulnerabilities

CVE-2017-18264

Description

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

Affected products

How to fix

Upgrade to a fixed version: phpMyAdmin 4.0.10.20. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-18264 or the next vulnerability affects your stack