What’s Vulnerable › Vulnerabilities
CVE-2017-18265
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-09 · updated 2026-06-17
Description
Prosody before 0.10.0 allows remote attackers to cause a denial of service (application crash), related to an incompatibility with certain versions of the LuaSocket library, such as the lua-socket package from Debian stretch. The attacker needs to trigger a stream error. A crash can be observed in, for example, the c2s module.
Affected products
- Debian Linux: 9.0
- Prosody: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Prosody 0.10.0. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/875829
- https://hg.prosody.im/0.9/rev/176b7f4e4ac9
- https://hg.prosody.im/0.9/rev/adfffc5b4e2a
- https://prosody.im/issues/issue/987
- https://www.debian.org/security/2018/dsa-4198
- https://bugs.debian.org/875829
- https://hg.prosody.im/0.9/rev/176b7f4e4ac9
- https://hg.prosody.im/0.9/rev/adfffc5b4e2a
- https://prosody.im/issues/issue/987
- https://www.debian.org/security/2018/dsa-4198
Get alerted when CVE-2017-18265 or the next vulnerability affects your stack