What’s Vulnerable › Vulnerabilities
CVE-2017-18266
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-10 · updated 2026-06-17
- Weakness: CWE-74
Description
The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- xdg-utils: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: xdg-utils 1.1.3. Check the vendor advisory for mitigations.
References
- https://bugs.freedesktop.org/show_bug.cgi?id=103807
- https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=5647afb35e4bcba2060148e1a2a47bc43cc240f2
- https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=ce802d71c3466d1dbb24f2fe9b6db82a1f899bcb
- https://cgit.freedesktop.org/xdg/xdg-utils/tree/ChangeLog
- https://lists.debian.org/debian-lts-announce/2018/05/msg00014.html
- https://usn.ubuntu.com/3650-1/
- https://www.debian.org/security/2018/dsa-4211
- https://bugs.freedesktop.org/show_bug.cgi?id=103807
- https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=5647afb35e4bcba2060148e1a2a47bc43cc240f2
- https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=ce802d71c3466d1dbb24f2fe9b6db82a1f899bcb
- https://cgit.freedesktop.org/xdg/xdg-utils/tree/ChangeLog
- https://lists.debian.org/debian-lts-announce/2018/05/msg00014.html
Get alerted when CVE-2017-18266 or the next vulnerability affects your stack