What’s Vulnerable › Vulnerabilities
CVE-2017-18350
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-12 · updated 2026-06-17
- Weakness: CWE-120
Description
bitcoind and Bitcoin-Qt prior to 0.15.1 have a stack-based buffer overflow if an attacker-controlled SOCKS proxy server is used. This results from an integer signedness error when the proxy server responds with an acknowledgement of an unexpected target domain name.
Affected products
- Bitcoin Core: before 0.15.1 — fixed in 0.15.1
How to fix
Upgrade to a fixed version: Bitcoin Core 0.15.1. Check the vendor advisory for mitigations.
References
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://medium.com/%40lukedashjr/cve-2017-18350-disclosure-fe6d695f45d5
- https://en.bitcoin.it/wiki/Common_Vulnerabilities_and_Exposures
- https://medium.com/%40lukedashjr/cve-2017-18350-disclosure-fe6d695f45d5
Get alerted when CVE-2017-18350 or the next vulnerability affects your stack