What’s Vulnerable › Vulnerabilities
CVE-2017-18356
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-15 · updated 2026-06-17
- Weakness: CWE-94
Description
In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible after gaining access to the target site with a user account that has at least Shop manager privileges. The attacker then constructs a specifically crafted string that will turn into a PHP object injection involving the includes/shortcodes/class-wc-shortcode-products.php WC_Shortcode_Products::get_products() use of cached queries within shortcodes.
Affected products
- Automattic WooCommerce: before 3.2.4 — fixed in 3.2.4
How to fix
Upgrade to a fixed version: Automattic WooCommerce 3.2.4. Check the vendor advisory for mitigations.
References
- https://blog.ripstech.com/2018/woocommerce-php-object-injection/
- https://woocommerce.wordpress.com/2017/11/16/woocommerce-3-2-4-security-fix-release-notes/
- https://blog.ripstech.com/2018/woocommerce-php-object-injection/
- https://woocommerce.wordpress.com/2017/11/16/woocommerce-3-2-4-security-fix-release-notes/
Get alerted when CVE-2017-18356 or the next vulnerability affects your stack