What’s Vulnerable › Vulnerabilities
CVE-2017-18359
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-25 · updated 2026-06-17
- Weakness: CWE-20
Description
PostGIS 2.x before 2.3.3, as used with PostgreSQL, allows remote attackers to cause a denial of service via crafted ST_AsX3D function input, as demonstrated by an abnormal server termination for "SELECT ST_AsX3D('LINESTRING EMPTY');" because empty geometries are mishandled.
Affected products
- Debian Linux: 8.0, 9.0
- PostGIS: from 2.0.0 before 2.3.3 — fixed in 2.3.3
How to fix
Upgrade to a fixed version: PostGIS 2.3.3. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2019/01/msg00030.html
- https://lists.debian.org/debian-lts-announce/2021/12/msg00020.html
- https://trac.osgeo.org/postgis/changeset/15444
- https://trac.osgeo.org/postgis/changeset/15445
- https://trac.osgeo.org/postgis/ticket/3704
- https://lists.debian.org/debian-lts-announce/2019/01/msg00030.html
- https://lists.debian.org/debian-lts-announce/2021/12/msg00020.html
- https://trac.osgeo.org/postgis/changeset/15444
- https://trac.osgeo.org/postgis/changeset/15445
- https://trac.osgeo.org/postgis/ticket/3704
Get alerted when CVE-2017-18359 or the next vulnerability affects your stack