What’s Vulnerable › Vulnerabilities
CVE-2017-18376
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-02 · updated 2026-06-17
- Weakness: CWE-264
Description
An improper authorization check in the User API in TheHive before 2.13.4 and 3.x before 3.3.1 allows users with read-only or read/write access to escalate their privileges to the administrator's privileges. This affects app/controllers/UserCtrl.scala.
Affected products
- StrangeBee TheHive: before 2.13.4; from 3.0.0 before 3.3.1 — fixed in 2.13.4, 3.3.1
How to fix
Upgrade to a fixed version: StrangeBee TheHive 2.13.4, 3.3.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/RaJiska/c1b4521aefd77ed43b06045ca05e2591
- https://github.com/TheHive-Project/TheHive/issues/408
- https://github.com/TheHive-Project/TheHive/releases/tag/3.3.1
- https://gist.github.com/RaJiska/c1b4521aefd77ed43b06045ca05e2591
- https://github.com/TheHive-Project/TheHive/issues/408
- https://github.com/TheHive-Project/TheHive/releases/tag/3.3.1
Get alerted when CVE-2017-18376 or the next vulnerability affects your stack