What’s Vulnerable › Vulnerabilities
CVE-2017-18379
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-27 · updated 2026-06-17
- Weakness: CWE-119
Description
In the Linux kernel before 4.14, an out of boundary access happened in drivers/nvme/target/fc.c.
Affected products
- Linux kernel: from 4.10 before 4.14 — fixed in 4.14
How to fix
Upgrade to a fixed version: Linux kernel 4.14. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=0c319d3a144d4b8f1ea2047fd614d2149b68f889
- https://github.com/torvalds/linux/commit/0c319d3a144d4b8f1ea2047fd614d2149b68f889
- https://support.f5.com/csp/article/K74012105
- https://support.f5.com/csp/article/K74012105?utm_source=f5support&%3Butm_medium=RSS
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=0c319d3a144d4b8f1ea2047fd614d2149b68f889
- https://github.com/torvalds/linux/commit/0c319d3a144d4b8f1ea2047fd614d2149b68f889
- https://support.f5.com/csp/article/K74012105
- https://support.f5.com/csp/article/K74012105?utm_source=f5support&%3Butm_medium=RSS
Get alerted when CVE-2017-18379 or the next vulnerability affects your stack