What’s Vulnerable › Vulnerabilities

CVE-2017-18509

Description

An issue was discovered in net/ipv6/ip6mr.c in the Linux kernel before 4.11. By setting a specific socket option, an attacker can control a pointer in kernel land and cause an inet_csk_listen_stop general protection fault, or potentially execute arbitrary code under certain circumstances. The issue can be triggered as root (e.g., inside a default LXC container or with the CAP_NET_ADMIN capability) or after namespace unsharing. This occurs because sk_type and protocol are not checked in the appropriate part of the ip6_mroute_* functions. NOTE: this affects Linux distributions that use 4.9.x longterm kernels before 4.9.187.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 3.16.72, 4.11, 4.4.187, 4.9.187. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2017-18509 or the next vulnerability affects your stack